summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog23
-rw-r--r--debian/control29
-rw-r--r--debian/copyright47
-rw-r--r--debian/gbp.conf3
-rw-r--r--debian/patches/golang-1.3-compat-readdir23
-rw-r--r--debian/patches/golang-1.3-compat-remove-prefix-logging14
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules7
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch4
10 files changed, 153 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..b6037ab
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,23 @@
+planr (0.0.3-2) focal; urgency=medium
+
+ * Fixed build depend for package
+
+ -- Alex David <flu0r1ne@flu0r1ne.net> Tue, 31 Aug 2021 01:37:24 -0500
+
+planr (0.0.3-1) focal; urgency=medium
+
+ * Fixed directory resolution for directories with special characters
+
+ -- Alex David <flu0r1ne@flu0r1ne.net> Mon, 30 Aug 2021 23:41:42 -0500
+
+planr (0.0.2-1) focal; urgency=medium
+
+ * Refactoring, colorized output, fenced blocks
+
+ -- Alex David <flu0r1ne@flu0r1ne.net> Mon, 30 Aug 2021 23:41:42 -0500
+
+planr (0.0.1-1) focal; urgency=medium
+
+ * Initial release
+
+ -- Alex David <flu0r1ne@flu0r1ne.net> Wed, 11 Aug 2021 23:44:29 -0500
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..9e8f295
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,29 @@
+Source: planr
+Maintainer: Alex David <flu0r1ne@flu0r1ne.net>
+Uploaders: Alex David <flu0r1ne@flu0r1ne.net>
+Section: devel
+Testsuite: autopkgtest-pkg-go
+Priority: optional
+Build-Depends: debhelper-compat (= 12),
+ dh-golang,
+ golang-any,
+ golang-toml-dev,
+ golang-github-fatih-color-dev
+Standards-Version: 4.5.0
+Vcs-Browser: https://www.git.flu0r1ne.net/deb-planr/
+Vcs-Git: https://git.flu0r1ne.net/deb-planr/
+Homepage: https://www.git.flu0r1ne.net/planr/about/
+Rules-Requires-Root: no
+XS-Go-Import-Path: golang.flu0r1ne.net/planr
+
+Package: planr
+Architecture: amd64
+Depends: ${misc:Depends},
+ ${shlibs:Depends},
+ cmake,
+ make
+Built-Using: ${misc:Built-Using}
+Description: An open-source, distrubed code grading tool for the classroom
+ PlanR aggregates various results from testing frameworks automating grading.
+ It aims to provide simple and modular configuration. The configuration.
+ language can provide context and grading information to test cases.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..03fd978
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,47 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: planr
+Upstream-Contact: Alex David <flu0r1ne@flu0r1ne.net>
+Source: https://www.git.flu0r1ne.net/planr
+
+Files: *
+Copyright: 2021 Alex David
+License: GPL-2+
+
+Files: debian/*
+Copyright: 2021 Alex David <flu0r1ne@flu0r1ne.net>
+License: GPL-2.0-only
+Comment: Debian packaging is licensed under the same terms as upstream
+
+License: GPL-2+
+ This program is free software; you can redistribute it
+ and/or modify it under the terms of the GNU General Public
+ License as published by the Free Software Foundation; either
+ version 2 of the License, or (at your option) any later
+ version.
+ .
+ In addition, as a special exception, the author of this
+ program gives permission to link the code of its
+ release with the OpenSSL project's "OpenSSL" library (or
+ with modified versions of it that use the same license as
+ the "OpenSSL" library), and distribute the linked
+ executables. You must obey the GNU General Public
+ License in all respects for all of the code used other
+ than "OpenSSL". If you modify this file, you may extend
+ this exception to your version of the file, but you are
+ not obligated to do so. If you do not wish to do so,
+ delete this exception statement from your version.
+ .
+ This program is distributed in the hope that it will be
+ useful, but WITHOUT ANY WARRANTY; without even the implied
+ warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
+ PURPOSE. See the GNU General Public License for more
+ details.
+ .
+ You should have received a copy of the GNU General Public
+ License along with this package; if not, write to the Free
+ Software Foundation, Inc., 51 Franklin St, Fifth Floor,
+ Boston, MA 02110-1301 USA
+ .
+ On Debian systems, the full text of the GNU General Public
+ License version 2 can be found in the file
+ `/usr/share/common-licenses/GPL-2'.
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..3d450c2
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,3 @@
+[DEFAULT]
+debian-branch = debian/sid
+dist = DEP14
diff --git a/debian/patches/golang-1.3-compat-readdir b/debian/patches/golang-1.3-compat-readdir
new file mode 100644
index 0000000..b9e5c6d
--- /dev/null
+++ b/debian/patches/golang-1.3-compat-readdir
@@ -0,0 +1,23 @@
+Index: planr/fs.go
+===================================================================
+--- planr.orig/fs.go
++++ planr/fs.go
+@@ -224,7 +224,7 @@ func collectFromDir(
+
+ // Read the entries in this directory
+ for {
+- dirs, err := fp.ReadDir(100)
++ dirs, err := fp.Readdir(100)
+ if err == io.EOF {
+ break
+ } else if err != nil {
+@@ -233,8 +233,8 @@ func collectFromDir(
+
+
+ for _, ent := range dirs {
+- child := path.Join(dir, ent.Name())
+ nm := ent.Name()
++ child := path.Join(dir, nm)
+
+ if ent.IsDir() {
+ collectFromDir(child, defaults, cfgs, units)
diff --git a/debian/patches/golang-1.3-compat-remove-prefix-logging b/debian/patches/golang-1.3-compat-remove-prefix-logging
new file mode 100644
index 0000000..08a1a9e
--- /dev/null
+++ b/debian/patches/golang-1.3-compat-remove-prefix-logging
@@ -0,0 +1,14 @@
+Index: planr/cmd/planr/main.go
+===================================================================
+--- planr.orig/cmd/planr/main.go
++++ planr/cmd/planr/main.go
+@@ -28,8 +28,7 @@ func dieUsage() {
+
+ func main() {
+
+- log.SetFlags(log.Llongfile | log.Lmsgprefix)
+- log.SetPrefix("planr: ")
++ log.SetFlags(log.Llongfile)
+
+ if len(os.Args) < 2 {
+ dieUsage()
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..a80079f
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+golang-1.3-compat-readdir
+golang-1.3-compat-remove-prefix-logging
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a97e135
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,7 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --builddirectory=_build --buildsystem=golang --with=golang
+
+override_dh_auto_install:
+ dh_auto_install -- --no-source
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..e054322
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,4 @@
+version=4
+opts="mode=git, gitmode=full, pgpmode=none" \
+https://git.flu0r1ne.net/planr \
+refs/tags/v([\d\.]+) debian uupdate