Index: planr/fs.go
===================================================================
--- planr.orig/fs.go
+++ planr/fs.go
@@ -220,7 +220,7 @@ func collectFromDir(
 
   // Read the entries in this directory
   for {
-    dirs, err := fp.ReadDir(100)
+    dirs, err := fp.Readdir(100)
     if err == io.EOF {
       break
     } else if err != nil {
@@ -229,8 +229,8 @@ func collectFromDir(
 
 
     for _, ent := range dirs {
-      child := path.Join(dir, ent.Name())
       nm := ent.Name()
+      child := path.Join(dir, nm)
 
       if ent.IsDir() {
         collectFromDir(child, defaults, cfgs, units)