summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorW-Mark Kubacki <wmark@hurrikane.de>2010-05-25 23:07:35 +0200
committerW-Mark Kubacki <wmark@hurrikane.de>2010-05-25 23:07:35 +0200
commit35364e13de7f992baaed35916dc1ef8a0b4d3edd (patch)
treee6cbdc3b5150c0d27c7fd705d79306128a6bcc90 /configure.ac
parent21e729d25d8b80f92f154a61fa8ea2b0aa918629 (diff)
downloadfcgiwrap-35364e13de7f992baaed35916dc1ef8a0b4d3edd.tar.xz
fcgiwrap-35364e13de7f992baaed35916dc1ef8a0b4d3edd.zip
fcgiwrap to rely on definitions provided by autoconf/autoreconf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 24c0a6e..06d1ed4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
-AC_INIT(fcgiwrap, 1.0, root@localdomain.pl)
+AC_INIT([fcgiwrap], [1.0.1], [root@localdomain.pl])
AM_CFLAGS="-std=gnu99 -Wall -Wextra -Werror -pedantic"
if test x"$CFLAGS" = x""; then
AM_CFLAGS="$AM_CFLAGS -O2 -g3"
@@ -15,6 +15,9 @@ AC_SUBST([AM_CFLAGS])
# Checks for programs.
AC_PROG_CC
+# Create the config.h.
+AC_CONFIG_HEADERS([config.h])
+
# Checks for libraries.
AC_CHECK_LIB([fcgi], [FCGX_Init],, [AC_MSG_ERROR([FastCGI library is missing])])