summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorW-Mark Kubacki <wmark@hurrikane.de>2010-03-18 13:47:13 +0100
committerW-Mark Kubacki <wmark@hurrikane.de>2010-03-18 13:47:13 +0100
commit957a3d1d3f76b54148d3ef67d19ba08c0c660eee (patch)
tree66aa1c44adb7b8ef221ec53a3b2a72e030666972 /configure.ac
parent94cd6dbe6705f17a1611e926333965b6e93dcccf (diff)
downloadfcgiwrap-957a3d1d3f76b54148d3ef67d19ba08c0c660eee.tar.xz
fcgiwrap-957a3d1d3f76b54148d3ef67d19ba08c0c660eee.zip
input files and substitution variables for autoconf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..53759f4
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,37 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.63)
+AC_INIT(fcgiwrap, 1.0, root@localdomain.pl)
+AM_CFLAGS="-std=gnu99 -Wall -Wextra -Werror -pedantic"
+if test x"$CFLAGS" = x""; then
+ AM_CFLAGS="$AM_CFLAGS -O2 -g3"
+else
+ AM_CFLAGS="$AM_CFLAGS $CFLAGS"
+fi
+
+AC_SUBST([AM_CFLAGS])
+
+# Checks for programs.
+AC_PROG_CC
+
+# Checks for libraries.
+AC_CHECK_LIB([fcgi], [FCGX_Init])
+
+# Checks for header files.
+AC_CHECK_HEADERS([fcntl.h limits.h stdlib.h string.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_TYPE_PID_T
+AC_TYPE_SIZE_T
+AC_TYPE_SSIZE_T
+
+# Checks for library functions.
+AC_FUNC_FORK
+AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
+AC_FUNC_MALLOC
+AC_CHECK_FUNCS([dup2 putenv select setenv strchr strdup strerror strrchr])
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT