summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGrzegorz Nosek <root@localdomain.pl>2012-08-21 05:47:22 -0700
committerGrzegorz Nosek <root@localdomain.pl>2012-08-21 05:47:22 -0700
commita7e3d397bad337d59519fa69eafee7ca1d83d551 (patch)
tree13957856c3125301f3967d8a2cf81c2711c33c20 /configure.ac
parent7f583a055c0a925c1b9dd25d7f831c5d6d9f4665 (diff)
parenta9784d8967975160d56fc191d85ced94143e89de (diff)
downloadfcgiwrap-a7e3d397bad337d59519fa69eafee7ca1d83d551.tar.xz
fcgiwrap-a7e3d397bad337d59519fa69eafee7ca1d83d551.zip
Merge pull request #7 from falconindy/systemd
add systemd unit files for installation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4388cd4..296ea75 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,6 +38,14 @@ if test "x$with_systemd" != "xno"; then
fi
AM_CONDITIONAL(HAVE_LIBSSL, [test "x$have_systemd" = "xyes"])
+AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ [], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+if test "x$with_systemdsystemunitdir" != xno -a "x$have_systemd" != xno; then
+ AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+fi
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != xno ])
+
# Checks for header files.
AC_CHECK_HEADERS([fcntl.h],, [AC_MSG_ERROR([fcntl.h header missing])])
AC_CHECK_HEADERS([limits.h stdlib.h string.h unistd.h],, [AC_MSG_ERROR([at least one important system header file is missing])])