summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorW-Mark Kubacki <wmark@hurrikane.de>2010-03-22 14:27:24 +0100
committerW-Mark Kubacki <wmark@hurrikane.de>2010-03-22 14:27:24 +0100
commitcdc355e7788c67d364d91ac700745f3af0cc94bd (patch)
treea4acb803390df1963431ce1a9ec7e2c5e42be4eb /configure.ac
parentd4877ae7110e5af55efcfef884aa9a446e5ed169 (diff)
downloadfcgiwrap-cdc355e7788c67d364d91ac700745f3af0cc94bd.tar.xz
fcgiwrap-cdc355e7788c67d364d91ac700745f3af0cc94bd.zip
oldest possible autoconf is 2.61, with separation of troublesome functions
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 07af4f0..e019983 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.63)
+AC_PREREQ(2.61)
AC_INIT(fcgiwrap, 1.0, root@localdomain.pl)
AM_CFLAGS="-std=gnu99 -Wall -Wextra -Werror -pedantic"
if test x"$CFLAGS" = x""; then
@@ -32,7 +32,8 @@ AC_TYPE_SSIZE_T
AC_FUNC_FORK
AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
AC_FUNC_MALLOC
-AC_CHECK_FUNCS([dup2 putenv select setenv strchr strdup strerror strrchr],, [AC_MSG_ERROR([seems as if your libraries doesn't provide an expected function])])
+AC_CHECK_FUNCS([strchr strdup strrchr])
+AC_CHECK_FUNCS([dup2 putenv select setenv strerror],, [AC_MSG_ERROR([seems as if your libraries doesn't provide an expected function])])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT