summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorW-Mark Kubacki <wmark@hurrikane.de>2010-03-22 13:59:56 +0100
committerW-Mark Kubacki <wmark@hurrikane.de>2010-03-22 13:59:56 +0100
commitd4877ae7110e5af55efcfef884aa9a446e5ed169 (patch)
tree614a56fb436d69a837e80ef5eaed9929b5de2d4c /configure.ac
parent41f6f848b3bd14d7a22f077fec04060b3d674a6e (diff)
downloadfcgiwrap-d4877ae7110e5af55efcfef884aa9a446e5ed169.tar.xz
fcgiwrap-d4877ae7110e5af55efcfef884aa9a446e5ed169.zip
abort configuration if something is missing
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 53759f4..07af4f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,10 +16,11 @@ AC_SUBST([AM_CFLAGS])
AC_PROG_CC
# Checks for libraries.
-AC_CHECK_LIB([fcgi], [FCGX_Init])
+AC_CHECK_LIB([fcgi], [FCGX_Init],, [AC_MSG_ERROR([FastCGI library is missing])])
# Checks for header files.
-AC_CHECK_HEADERS([fcntl.h limits.h stdlib.h string.h unistd.h])
+AC_CHECK_HEADERS([fcntl.h],, [AC_MSG_ERROR([fcntl.h header missing])])
+AC_CHECK_HEADERS([limits.h stdlib.h string.h unistd.h],, [AC_MSG_ERROR([at least one important system header file is missing])])
# Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_STDBOOL
@@ -31,7 +32,7 @@ AC_TYPE_SSIZE_T
AC_FUNC_FORK
AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
AC_FUNC_MALLOC
-AC_CHECK_FUNCS([dup2 putenv select setenv strchr strdup strerror strrchr])
+AC_CHECK_FUNCS([dup2 putenv select setenv strchr strdup strerror strrchr],, [AC_MSG_ERROR([seems as if your libraries doesn't provide an expected function])])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT