aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorflu0r1ne <flu0r1ne@flu0r1ne.net>2023-05-09 15:57:05 -0500
committerflu0r1ne <flu0r1ne@flu0r1ne.net>2023-05-09 15:57:05 -0500
commit4f684f7073149c48ea9dd962b64a8bf7a169a1cf (patch)
tree3d642519b77bf9a6e451af62e7a50d7ee99f5a1d /setup.py
parent61a9d6426cdb0e32436b704561b7a3ff47b60b04 (diff)
downloadgpt-chat-cli-4f684f7073149c48ea9dd962b64a8bf7a169a1cf.tar.xz
gpt-chat-cli-4f684f7073149c48ea9dd962b64a8bf7a169a1cf.zip
Rewrote the argparsing functionality to enable autocompletion via the "kislyuk/argcomplete" package.
This essentially means: - `argparsing.py` does a minimal amount of work to initialize the arg parser. Then it attempts dynamic completion. - `argvalidation.py` processes the raw arguments parsed in `argparsing.py`, validates them, issues warnings (if required), and splits them into logical groupings - Commands in `gcli.py` have been moved to `cmd.py` - `main.py` provides an initial control path to call these functions in succession
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 269dc73..07740e6 100644
--- a/setup.py
+++ b/setup.py
@@ -2,9 +2,9 @@ import setuptools
setuptools.setup(
name='gpt-chat-cli',
- version='0.1.2',
+ version='0.2.2-alpha',
entry_points = {
- 'console_scripts': ['gpt-chat-cli=gpt_chat_cli.gcli:main'],
+ 'console_scripts': ['gpt-chat-cli=gpt_chat_cli.main:main'],
},
author='Flu0r1ne',
description='A simple ChatGPT CLI',
@@ -13,7 +13,8 @@ setuptools.setup(
install_requires=[
'setuptools',
'openai >= 0.27.6',
- 'pygments >= 0.15.0'
+ 'pygments >= 0.15.0',
+ 'argcomplete >= 3.0.8',
],
python_requires='>=3.7'
)